Zettelkasten Forum


[SOLVED] Stop beeping when hitting Cmd+S

edited March 23 in The Archive

I'm a seasoned developer working on computers for decades now. So formely on Windows Strg+s and since 2016 on my MacBook Cmd+s are burned in my DNA. I cannot NOT press those keys on a regular basis.

Unfortunately on Zettelkasten everytime I do this I'm alerted by the system with this nagging sound. Since I'm new to Zettelkasten I'd wanted to ask experienced users if it is possible to disable auto-save. Is it possible?

Post edited by ctietze on

Comments

  • Seconded!

    But instead of changing the auto-save function, would it be possible just to disable the alert sound? I actually don't care if cmd-s doesn't do anything in The Archive, if auto-save is doing its saving thing anyway. I just compulsively click cmd+s when I write, more as a nervous tick than as a desire to save whatever junk I've just written. ;)

  • I actually hit Cmd+S myself from time to time and get confused by the system beep. It's a good idea to at least not make the sound.

    Author at Zettelkasten.de • https://christiantietze.de/

  • No system error sound anymore with the latest v1.5.1 from the Cutting Edge update channel 🎉

    Author at Zettelkasten.de • https://christiantietze.de/

  • v1.5.2 lets you hit ⌘S to save with a regular menu shortcut; I added a contextual hint in case folks don't know that saving is unnecessary. It triggers when you hit ⌘S for 10, 100, and 1000 times :)

    Feedback welcome!

    Author at Zettelkasten.de • https://christiantietze.de/

Sign In or Register to comment.