Zettelkasten Forum

Problem with Catalina

I just upgraded my OSX to Catalina and now when I open The Archive I can't access any of my notes. Does anybody know a solution for this?


  • Hm.... I use it on Catalina and it's working fine. I recall that when I upgraded I may have had to reset the path to my notes folder --- I just changed it to something else and then changed it back.

  • With Catalina, apps don't even know when they don't have access to some features due to the tightened security restrictions. "Full Disk Access" is one such thing. The OS requests permission once, that's it. You cannot ask users for permission again. Ever.

    I'm not yet on Catalina for various reasons (I just notice too many problems with backups, Email, disk integrity, ...) but maybe you can try

    1. to change the note directory as @zvt suggested, from the app's settings
    2. if that still doesn't yield any results, see how you can grant Full Disk Access to an app manually and see if that helps

    Author at Zettelkasten.de • https://christiantietze.de/

  • Thank you! This worked. Resetting the note directory wasn't an option because most of the meanu options within the app had been disabled. But granting Full Disk Access solved everything.

  • In case this is a relevant detail (for others who might find themselves in this situation): this situation arose not from a system upgrade but from migrating to a new computer.

Sign In or Register to comment.