Zettelkasten Forum

[SOLVED] [BUG] URL Scheme doesn't work when app is inactive

edited July 6 in The Archive

Below are steps on how to reproduce the bug:

  1. Close TheArchive.
  2. Open URL thearchive://match/201810111523 (e.g. using open command in a terminal).
  3. TheArchive will open but the note won’t be shown.
  4. If you open the same URL while TheArchive is active then the note would be shown.

The bug is present both in version 1.1.0 (109) and in version 1.1.3 (113) on macOS 10.14.1 (18B75). Let me know if you need more information from me!

I also tried to submit this bug to hi@christiantietze.de a couple months ago but unfortunately, haven't gotten any response.


  • Thanks for reporting this! Sorry if I didn't respond. Seems this one fell through the cracks.

    I edited your post's title to be more specific.

    Author at Zettelkasten.de • https://christiantietze.de/

  • And I thought it was me going insane :D

    Thanks for helping me keep my sanity, @maltsev!

  • @ctietze I just fell into yet another Zettelkasten rabbit hole (how can you not with the Luhmann archive having come online…), and remembered that this remains one of the few things to resolve in my workflow. I am not sure whether you keep issues like these in some place where I can track them without having to bother you and ask?

  • Solved with v1.3.1, available today!

    Author at Zettelkasten.de • https://christiantietze.de/

  • Thank you very much @ctietze very cool!

Sign In or Register to comment.