Zettelkasten Forum

Bug? TheArchive seems to «forget» any configuration on exit

edited December 2020 in Resolved Issues

Every time I start The Archive it creates and loads the default ~/Notes (The Archive) Archive instead of loading the previous Archive created by me. Moreover, it keeps adding a new #thearchive search space button every time I start. (Right now I have three such buttons on my search space bar.)

I tried uninstalling and deleting every related file I could find under ~/Library/{Application Support, Preferences, Logs, Caches} , but the issue persists. Of course I didn't manage to delete everything as it still recalls my Registration Name and Code upon installing, though.

This issue started to occur right after I upgraded my (long-expired) trial version.

What other information would be useful for troubleshooting?

Thanks in advance for any help!

Post edited by ctietze on


  • @tsgz It's easier if you drop me an email so we can exchange data about your computer.

    For others running into similar problems, I'd first try to log-in as a Guest user (or temporary user) and see if the Guest/temp user works fine, because this sounds very much like the access rights to the place where preferences are stored are broken.

    Author at Zettelkasten.de • https://christiantietze.de/

  • edited December 2020

    Thanks for the quick and helpful response :)

    I uninstalled and found more related files I could delete (searching for both zettelkasten and thearchive in Finder this time). Once I reinstalled, everything started to work as expected again. So, that solved my problem. Cheers!

Sign In or Register to comment.