Zettelkasten Forum


[RTL support] Hebrew word jumps to the end of the line

If we type a Hebrew word as first word in a paragraph, it jumps to the end of the line. This is good for paragraphs that are written in Hebrew, but if I want to make e.g. a lexical statement like:

בְּרֵאשִׁית means in the beginning …,

(which works good in this text field, by the way)

then in The Archive the first word of this new paragraph is "means", not "בְּרֵאשִׁית" as it should, and the asterisks for the italics are wrong positioned, too.

Other Mac text editors like BBEdit let me type that right without problems or correction, in RTF editors I can correct the writing direction, at least.

Besides, I know that this is a bug within NSTextField, that tries to do the right thing for Hebrew, but it doesn’t (a Hebrew paragraph would all the time begin at the right margin).

It would be a good start if we could define the main writing direction (left to right; right to left) for all documents in the preferences of The Archive. Left to right for all documents would solve every Hebrew problems in The Archive for me.

Help your customers that write in left to right languages with words or phrases in right to left languages, please!

Comments

  • Thanks for bringing this to my attention! I was neither aware that Mac default text components try to be clever, nor that it's not even desirable. I'll look into this issue and see how to fix it.

    Author at Zettelkasten.de • https://christiantietze.de/

  • edited January 21

    That would be great, thank you! I’ve just seen that there is the menu entry View / Editor Font / Writing Direction, but it does’nt help:

    So I hope that you can fix it. Thank you so much in advance!

  • Could you please send me details about what remedies the built-in TextEdit offers? Bidirectionality seems to be the culprit, which I think I can disable with an additional toggle in that menu, but it'd be great to know what measures work for you already!

    Author at Zettelkasten.de • https://christiantietze.de/

  • Sure! Typing in TextEdit leads to the same rubbish as in The Archive:

    But then we can choose Format / Text / Richtung beim Schreiben / Von links nach rechts (German GUI) and get it right (you see the result of the menu command highlighted in blue):

    In The Archive it doesn’t work if I choose View / Editor Font / Writing Direction.

    It would be the best and easiest solution if we could have checkboxes in the preferences where we choose if our documents should be oriented

    • left-to-right (for all who write in LTR languages with just words or phrases in RTL languages like me) or
    • right-to-left (for all who write in Hebrew or Arabic or other RTL languages with just LTR words or phrases)
    • or as they are now

    and if the documents should be aligned

    • left (for LTR texts with RTL words),
    • right (for RTL texts with LTR words).

    Easy. :wink:

    I think it really would be easy to do the overall left-to-right orientation. And it would be the solution for (me and) all who need just words and phrases in RTL languages, but write in English, German, French, Italian, Spanish etc.

    (There maybe will be difficulties with the right-to-left orientation because tabs and tables don’t behave right with only defining the right margin as starting point.)

    Please ask me if you need to know more. I’ve bought The Archive over a year ago and could not use it for real work. That’s why I’m happy to help you help me!

  • Thanks! So this confirms that the same setting from TextEdit does not affect writing in The Archive as expected. That's a good place to start fixing the behavior of the editor 👍

    Author at Zettelkasten.de • https://christiantietze.de/

  • Did you find a way to get the default writing direction for all text from left to right?

Sign In or Register to comment.