Zettelkasten Forum


Images not displaying inline

edited June 27 in The Archive

I'm new to using images in notes, and am finding they do not display in The Archive (but do in Obsidian).
They are formatted like this:
![Parliament_oob.jpg](/assets/ECW/Parliament_oob.jpg)
Am I doing something wrong?
Thanks,
Ian
PS The notes are stored in iCloud, in a 1Writer notes folder. Don't know if that affects things...

Comments

  • Hmm, let's see:

    First, please make sure that this is the only content on the line to rule out anything else getting in the way.

    The path you have there starts with a forward slash, denoting an absolute path, which is likely not what you want. I guess you want to use the 'assets' folder inside your notes folder. To do that, write ./assets/ECW/Parliament_oob.jpg or just assets/ECW/Parliament_oob.jpg.

    If you want to see what an absolute path to your image would look like, navigate to the image in Finder and drag & drop it into The Archive's text editor pane. It'll insert the path to the file. (You could use that for images, too, but relative paths are mostly what you're going to need)

    Author at Zettelkasten.de • https://christiantietze.de/

  • Did you do execute the following command in the terminal app?

    open thearchive://preference/enableInlineImagePreview/set/true

  • For reference: this is a way to change the preferences, even some of those that aren't part of the apps preferences window but useful for debugging.

    See a list of "hidden preferences" here:
    https://zettelkasten.de/the-archive/help/#hidden-preferences

    By default, inline image preview is enabled, so readers that didn't previously turn this off during the beta will not need to enable this.

    Author at Zettelkasten.de • https://christiantietze.de/

Sign In or Register to comment.