Zettelkasten Forum


Rene's SublimeText for Zettelkasten - Package, Talk and more

15678911»

Comments

  • Hi @m0hawk, thanks for answer.
    Yes, I use ag and probably there is a problem. The same situation is with tags and #1. So, as a (not perfect) solution, I convert tags to latin letters. I googled about UTF-8 and ag and find similar questions.

  • @damaskin You could look around for an ag fork that handles Cyrillic better. When installing it for windows, I found that the default one did not handle umlauts (äöü) but then I found a fork for windows that worked like a charm.

  • @m0hawk said:
    @damaskin You could look around for an ag fork that handles Cyrillic better. When installing it for windows, I found that the default one did not handle umlauts (äöü) but then I found a fork for windows that worked like a charm.

    Good, I don't know that exist. Do you have a link, please?

  • Done! All works with Cyrillic!
    Thank you @m0hawk to idea to look for fork.
    Download ag from here

  • @damaskin I am using this one for windows. Looks like there is additional stuff for Windows in there.

  • Hello! It seems that this conversation on Sublime-zk is not that active. However, I thought I would post here anyway as I have tried so many different Zettelkasten softwares, and have found that Sublime is my favorite interface, so I downloaded the Sublime-zk package today and love it so far!

    I have a quick question regarding retroactively giving UID's to files. I have a ton of notes that were taken before I began using any sort of Zettelkasten method. And at times, I would like to be able to link to these other notes. They are in my directory, and I can successfully search for them using [[. However, when I try selecting the corresponding file to create a link to it, it doesn't work.

    • Do all of my files need an actual timestamp-style UID of for them to be linked to?
    • If so, is there a way to easily retroactively do so to file names?
    • My ideas for this would be:
      • Just write a script that gives the filenames of my former notes a timestamp-like number, such as YYYYMMDDHHMM = 000000000001, 000000000001, ...
      • Or maybe adding some sort of metadata header to each file that specifies a UID like above

    Any support would be greatly appreciated! Thanks!

  • edited September 23

    Hey @electriclady
    From what I remember, the plugin links notes through the UID in the filename, so you'd either have to mod the python code or add UIDs to your files.
    Depending on the number of your files, a script would be the easiest way.
    Here is a draft (haven't tried it so be cautius and backup your notes before) i quickly threw together:

    import os 
    index = 1
    for filename in os.listdir("./"): 
        if filename.endswith(".md") and not filename[:12].isdigit():
            id = ["0"] * (12 - len(str(index)))
            id = "".join(id) + str(index) + " "
            os.rename(filename, id + filename)
            index += 1
    

    When run in the directory with your notes (or a copy of them, just to be save), this should rename all .md files that don't have 12 digits at the start of their filename and add a 12 digit UID starting from 000000000001 to the beginning of the filename.

  • edited September 23

    @m0hawk, thank you for your response!

    Yes, that's exactly what I thought I would have to do, which is totally fine. (And thank you for the starter script to use for this!) Also, have found where in the python code this would need to be changed... but I think for now will start with just changing the filenames.

  • Hi,

    Recently, in the last version, pandoc change citation aproach. So instead of using --filter pandoc-citeproc command is now --citeproc.

    After using Auto-bib in Sublime_zk I receive this

    [@Levy.2005]: (no bib generated)

    Any way to fix this, please?

  • @damaskin
    Hi,
    You have to mod the package yourself I fear. But it's a rather easy fix.
    Go to Preferences -> Browse Packages in sublime, open the sublime_zk folder and then open the sublime_zk.py file in eg. sublime ;)

    Then change line 636 from args = [pandoc_bin, '-t', 'plain', '--bibliography', bibfile] to args = [pandoc_bin, '-t', 'plain', '--bibliography', bibfile, '--citeproc']

    I feel like maybe I should start a fork and add all these small things there...

  • edited October 19

    @m0hawk said:

    Then change line 636 from args = [pandoc_bin, '-t', 'plain', '--bibliography', bibfile] to args = [pandoc_bin, '-t', 'plain', '--bibliography', bibfile, '--citeproc']

    It's working. Thank you so much! Persons like you, willing to help, make Internet great.

    I feel like maybe I should start a fork and add all these small things there...

    Yes, please!

    ~~Err, may I ask one more question. I ask this on GitHub, but there is no answer.
    In Pandoc package old settings are: ~~<\del>

    "Microsoft Word": {
    
            "scope": {
    
              "text.html": "html",
    
              "text.html.markdown": "markdown"
    
            },
    
            "pandoc-arguments": [
    
              "-t", "docx",  
    
              "--filter", "C:/Users/Kindan/AppData/Local/Pandoc/pandoc-citeproc.exe"
    
             ]
    
          },
    

    What I have to insert instead

    "--filter", "C:/Users/Kindan/AppData/Local/Pandoc/pandoc-citeproc.exe"?

    EDIT: Find the solution

              "--citeproc", "-t", "docx",  
              //"--filter", "C:/Users/Kindan/AppData/Local/Pandoc/pandoc-citeproc.exe"
    
Sign In or Register to comment.